US-Signale über Funktionsgenerator

Fragen zu Decoder Konfigurationen und CV-Sets, Beispiele aus der Praxis
Antworten
Exsachse
Beiträge: 76
Registriert: 05.04.2015, 22:08

US-Signale über Funktionsgenerator

Beitrag von Exsachse »

Hallo,

ich möchte US-Signale über einen ZA1-16+ ansteuern.
Ich habe mit einem Signal mit 3 je zweifarbigen! Lampen begonnen.
Ein CV-Set für den Funktionsgenerator habe ich erstellt.
Mein Problem ist jetzt, wie muss ich den Decoder konfigurieren.

Was ich erreichen will:
Signal mit 3 Lampen:
oben: rot oder gelb
mitte: rot oder grün-blinkend oder grün-dauer
unten:rot oder gelb-blinkend

Dafür 6 Ausgänge:
A1 rot oben
A2 gelb oben
A3 rot mitte
A4 grün mitte dauer oder blinkend
A5 rot unten
A6 gelb unten blinkend

Die Ansteuerung wie folgt:
Adr rot: A1+A3+A5
Adr grün: A2+A4blinkend+A5
Adr+1 rot: A1+A4dauer+A6blinkend

Der Funktionsgenerator war schnell erstellt. Was ich nicht hinbekommen hatte, war die Adressierung. In einer Doku von 2015 "Signalgenerator" habe ich dann gefunden CV1= Basisadresse und CV550= Anzahl der Signalbilder. Beides lässt sich in Qrail nicht definieren, also die CV einzeln programmiert.
Jetzt funktioniert das Ganze halbwegs, noch 2 Probleme:
Wie bekomme ich den Ausgang 4 im FG zwischen Dauer- und Blinklicht umgeschaltet, mit Mode 1 und 18 funktioniert das nicht.
die beiden ersten Signalbilder auf der Adresse 1 funktionieren richtig. Wird aber einmal das Signalbild 3 auf Adr 2rot eingeschaltet, leuchtet das richtig, aber diese 3 Ausgänge bleiben dann immer an, wieso?
US-Signal.zip
(25.87 KiB) 100-mal heruntergeladen
Die Config-Datei ist auf einmal 257KB groß, deshalb gezipt.
Es muss noch CV1=1 und CV550=3 gesetzt werden

Viele Grüße und frohe Ostern
Ludwig
Zuletzt geändert von Exsachse am 04.04.2021, 16:39, insgesamt 2-mal geändert.
Viele Grüße Ludwig.
Antworten