Servo-Ansteuerung mit ZA2-16+deluxe

Alle Fragen rund um den Qdecoder
eisenbahnochse
Beiträge: 13
Registriert: 22.04.2018, 21:02

Servo-Ansteuerung mit ZA2-16+deluxe

Beitrag von eisenbahnochse » 22.04.2018, 22:02

Hallo,
Habe ein Set QD095 bestellt und mache erste Erfahrungen damit, allerding mit zunächst ernüchternden Ergebnissen.
Die Servos stellen sich mit sehr ruckelnden, zappelnden Bewegungen, drei verschiedene Typen getestet. Eine ruhige, gleichmäßige Bwegung scheint nicht möglich zu sein. Schlimmer ist aber noch das der Servo seine angefahrene Position nicht behält, sondern in kleineren Schritten in willkürlichen Zeitabständen von 1-30 Sekunden Richtung rechten Endanschlag fährt und dort immer wieder kurz zuckt.
erteilt man einen Stellbefehl in der Programmersoftware so schippt er in die vorher angefahrene ausgangsposition, um dann die andere Schaltposition anzufahren. Diese wird aber auch wieder Richtung rechten Anschlag verlassen. Ob ich die Konfiguration Als Weichen- Schranken- oder Signalservo vornehme scheint keinen Unterschied zu machen. Beide Decoder reagieren gleich. Software-Update brachte nichts, war glaug ich auch eher ein downgrade. Variation der Stromversorgung brachte auch nichts (versuchsweise 5 Volt aus Batterie) (Decoder auch extern versorgt statt über Q-Programmer). Habe bislang nur jeweils ein Servo an verschiedenen Ausgängen probiert.
Gibt es Ideen was ich falsch gemacht haben könnte, oder welche CV noch zusätzlich zum Drag and Drop- Verfahren gesetzt werden müßten?

Mit freundlichen Grüßen
Frank Häßner
MEC Weida

Andh
Beiträge: 456
Registriert: 03.04.2015, 14:53

Re: Servo-Ansteuerung mit ZA2-16+deluxe

Beitrag von Andh » 23.04.2018, 10:31

Hallo Frank,

das klingt nach einer Softwareversion 9.14 oder niedriger!

Mit dem "Downgrade" hast du dir keinen Gefallen getan.
Die Decoder sollte die Software-Version 9.19 haben.
Auch wenn diese zur Zeit noch als Testfirmware bezeichnet wird, wird diese in den nächsten Tagen als Standardversion freigegeben.
Seit ca. 14 Tagen werden von uns alle Decoder mit diese Softwareversion ausgeliefert.

Außerdem sollte das 5V-Netzteil kräftig genug sein (500mA pro Servo, aber min 1A).

Beim ZA2-16+ deluxe sollte bei Verwendung der Ausgänge an den Schraubklemmen, die nicht deluxe Software verwendet werden.
Die deluxe Software verdreht die Ausgangsbelegung, so dass die Multiplexsignale richtig angesteuert werden.
Gruss aus Dresden
Andreas Hillert

Qdecoder Support Team

www.qdecoder.de
info(at)qdecoder.com
Tel: 0351/50036-95

eisenbahnochse
Beiträge: 13
Registriert: 22.04.2018, 21:02

Re: Servo-Ansteuerung mit ZA2-16+deluxe

Beitrag von eisenbahnochse » 23.04.2018, 15:10

Hallo,
Was bedeutet konkret " nicht die deluxe-Software verwenden" - anderes Update, oder bei programmierung anderen Typ angeben?
Mit der originalen Software 9.19 war es nicht anders, weshalb ich das Down-grade überhaupt machte, kann nicht die Ursache sein.
Wenn nach der Stellbewegung der Stellimpuls eigentlich abgeschaltet wird, sollte sich doch nichts mehr bewegen. Tut es aber zielgerichtet nach Rechts!
Das Universalnetzteil liefert 90Watt, der Nachgeordnete Festspannungsregler ist bis 1A spezifiziert das muß doch für 1 Servo ohne mechanische Last, noch dazu in Ruhe, ausreichen?

Gruß Frank

Andh
Beiträge: 456
Registriert: 03.04.2015, 14:53

Re: Servo-Ansteuerung mit ZA2-16+deluxe

Beitrag von Andh » 23.04.2018, 15:47

Hallo Frank,

du solltest auf dem ZA2-16+ deluxe die Software 9.19 für ZA2-16+ durch Qdecoder Update aufspielen.
Die Softwareänderungen der 9.19 sind für den deLuxe nicht von Interesse, weshalb es sein kann, dass diese in der Testfirmeware beim deLuxe noch nicht dabei sind.

Um was für einen Servo handelt es sich?
Wir haben hier analog wie digital-Servos von billig China zu nahmhaften Modellbau-Herstellern getestet und mit der 9.19 trat bei keinem der Servos mehr ein solches Verhalten auf.
Gruss aus Dresden
Andreas Hillert

Qdecoder Support Team

www.qdecoder.de
info(at)qdecoder.com
Tel: 0351/50036-95

eisenbahnochse
Beiträge: 13
Registriert: 22.04.2018, 21:02

Re: Servo-Ansteuerung mit ZA2-16+deluxe

Beitrag von eisenbahnochse » 24.04.2018, 13:33

Hallo Andreas,
Ich teste mit Decodern von Esu (nicht gelabelt), MG90S (billig aus China) und Lineare Mikroservos. Alle vergleichbares Verhalten und egal ob Softwareversion 9.19. oder 9.14.
Das Thema Stromversorgung nimmt ja breiten Raum ein. So tauschte ich das Schaltnetzteil vor dem Festspannungsregler gegen einen potenten Trafo mit 15V Leerlaufspannung aus. Der Decoder war ebenfalls auf diesen geklemmt. das führte zum Defekt desselben! Offensichtlich gibt es da einen Kurzschluß zwischen Betriebsspannung und Ausgang. Die 15V sind eigentlich innerhalb der Spezifikationen. Die Digitalspannung vom Programmer war in dem Moment noch aus.
Meiner Meinung nach gehört nun ein Hinweis in die Beschreibung das Die 5V potentialfrei erzeugt werden müssen!
Könnte ich den Decoder zwecks Reparatur zusenden, oder ist dies Option obsolet? Gibt es ggf. Ersatz? Zum Glück hat das Set einen 2. Decoder.
Ich habe drei Verschiedene 5V-Stromquellen ausprobiert, die fallen als Ursache definitiv weg.

Eine Frage hast du mir nicht konkret beantwortet! :
Was bedeutet konkret " nicht die deluxe-Software verwenden" - anderes Update, oder bei Programmierung anderen Typ angeben?

Ich habe nun ein Profil als ZA2-16+ (ohne Deluxe) erstellt. Und siehe da der Servo zeigt Manieren, läuft ruhig, zappelt nicht mehr so und zuckt auch nicht mehr Richtung Anschlag. Auch die Stromimpulse fallen geringer aus.
Welcher Anwender soll bitteschön auf die Idee kommen das so tun zu müssen?! Legt einen Hinweis bei!!!! Ich bin eigentlich außer mir!
Das ganze Gesuche und Geteste hat mich viele verzweifelte Stunden, ja Tage gekostet!

Ein Problemchen ist da aber noch: Wenn ich auf "alle CV´s senden" klicke zuckt das Ruderhorn heftig, auch außerhalb der programmierten linken und rechten Position Richtung Anschlag. Wenn da ein mit viel Mühe gebautes Modell dranhängt ist das möglicherweise kaputt.
Ist das noch abstellbar?

MfG
Frank Häßner
MEC Weida
Wiedenstraße 21
07570 Weida

Andh
Beiträge: 456
Registriert: 03.04.2015, 14:53

Re: Servo-Ansteuerung mit ZA2-16+deluxe

Beitrag von Andh » 24.04.2018, 14:18

Hallo Frank,

der Ausfall ist echt ärgerlich.
Wenn man die 5V, wie in der Anleitung gezeichnet, anschließt, dann haben Decoder und die 5V die gleiche Masse und es dürfte keine Probleme geben.
Erst recht nicht, wenn du den gleichen Trafo verwendest.
connect_servo.png
connect_servo.png (82.37 KiB) 337 mal betrachtet


Wie auch immer, sende den defekten Decoder an unsere Einsendeadresse (Berstraße 4) und du erhälst Ersatz. :cry:

Für uns ist es aber trotzdem wichtig zu wissen, ob die Masseverbindung zwischen den 5V und dem Decoder bestand, als dieser sich verabschiedet hat.


Was bedeutet "nicht die deLuxe Sofware verwenden"?:
So wie du es wahrscheinlich jetzt gemacht hast.
1) Qrail, "Decoder Update Wizard" wählen
2) "Decodertyp ändern" wählen
3) ZA2-16+ statt ZA2-16+ deLuxe wählen
4) Testsoftware 9.19 wählen

decodertyp_aendern.png
decodertyp_aendern.png (73.71 KiB) 325 mal betrachtet

Der ZA2-16+ deLuxe wird in der Regel für Viessmann Multiplex-Signale gekauft.
Aus diesem Grund ist in der Firmware 9.19 beim ZA2-16+ deLuxe noch nicht die neueste Servoansteuerung drin gewesen.
Wir entschuldigen uns dafür und beheben das Problem umgehend.
Zuletzt geändert von Andh am 24.04.2018, 21:56, insgesamt 1-mal geändert.
Gruss aus Dresden
Andreas Hillert

Qdecoder Support Team

www.qdecoder.de
info(at)qdecoder.com
Tel: 0351/50036-95

eisenbahnochse
Beiträge: 13
Registriert: 22.04.2018, 21:02

Re: Servo-Ansteuerung mit ZA2-16+deluxe

Beitrag von eisenbahnochse » 24.04.2018, 16:10

Hallo Andreas,

nein ganz so habe ich es nicht gemacht, den Softwarestand 9.19 kann ich nicht downloaden, finde ich nicht im Betabereich.
Ich habe lediglich beim Erstellen des Profils im Qprogrammer den ZA2-16+ (Ohne deluxe) ausgewählt, also eigentlich vermeintlich den nächst niedrigeren.
Wir haben den deluxe genommen wegen der abziehbaren Schraubklemmen, Lichtsignale sind eigentlich nicht unser Thema.

Ja die Masseverbindung zwischen 5V und Decodermasse hat wärend des Fehlers bestanden.

Gruß Frank

Andh
Beiträge: 456
Registriert: 03.04.2015, 14:53

Re: Servo-Ansteuerung mit ZA2-16+deluxe

Beitrag von Andh » 24.04.2018, 21:54

Danke für die Antwort Frank,

ich werde in den nächsten Tagen deinen Aufbau mal nachstellen und testen.

Wenn du die 9.19 selbst nach Aktivierung des Kontrollkästchens "Auch Testfimware anzeigen" nicht angeboten bekommst, dann musst du mal ein Update der Qrail-Software machen.
qrail_update.png
qrail_update.png (47.38 KiB) 325 mal betrachtet
Gruss aus Dresden
Andreas Hillert

Qdecoder Support Team

www.qdecoder.de
info(at)qdecoder.com
Tel: 0351/50036-95

eisenbahnochse
Beiträge: 13
Registriert: 22.04.2018, 21:02

Re: Servo-Ansteuerung mit ZA2-16+deluxe

Beitrag von eisenbahnochse » 26.04.2018, 22:14

Hallo Andreas,

ich habe das Update 9.19. dann doch noch gefunden und durchgeführt.
Ich habe eben vorher abgebrochen, mich nicht getraut weiter zu klicken. Wenn man die Programmer-Software nicht kennt denkt man nicht das die noch kommt eine Ebene weiter, da fehlt eigentlich eine Anleitung dazu.

den defekten Decoder sende ich ein.
Ich bedanke mich für die Unterstützung.
MfG
Frank Häßner

Andh
Beiträge: 456
Registriert: 03.04.2015, 14:53

Re: Servo-Ansteuerung mit ZA2-16+deluxe

Beitrag von Andh » 27.04.2018, 12:00

Hallo Frank,

das mit der Anleitung kann ich so nicht im Raum stehen lassen.
Zum Qprogrammer ist eine bebilderte Anleitung dazu, die den Updateprozess komplett beschreibt:
http://www.qdecoder.de/index.php?option ... 92&lang=de

Weiterhin ist die Hilfe in Qrail eine der Besten, die ich im Bereich Software kenne.

Die Dokumentation von komplizierten und umfangreichen Funktion ist eine aufwendige und nicht einfache Aufgabe.
Wir haben deshalb auch einige Kritik für unsere Anleitungen geärntet.
Wir versuchen in diesem Bereich kontinuierlich besser zu werden.

Man muss die schwer erarbeitete Dokumentation nur auch nutzen! :evil:
Gruss aus Dresden
Andreas Hillert

Qdecoder Support Team

www.qdecoder.de
info(at)qdecoder.com
Tel: 0351/50036-95

Antworten