SV Signale mit Z2-8 Signal nogo

Alle Fragen rund um den Qdecoder Programmer
Antworten
BeaNoone
Beiträge: 10
Registriert: 28.01.2017, 18:25

SV Signale mit Z2-8 Signal nogo

Beitrag von BeaNoone » 28.01.2017, 19:46

Hallo zusammen, bin neu hier und habe ein paar gravierende Probleme.

Ich habe versucht mehrere SV Signale zu programmieren, darunter die Modi 92 und 93 mit (-) als gemeinsame Elektrode (deshalb Z2).
1. Problem
Zuerst habe ich die CV's mit der Intellibox 1 eingegeben, was zu keinerlei funktionstüchtigem Signalbild führte. Oftmals brannte gar keine Led oder nur ein Teil. Reset über CV 8 war nicht moeglich und manche CV's ergaben bei jedem Lesevorgang andere Ergebnisse. Kurzum keine Lösung, scheint ein grundsätzliches HW Problem mit der alten IB zu sein. Daraufhin leistete ich mir einen QProgrammer mit Debugleiste, was aber zu weiteren Problemen führte
2. Problem
Qrail erkennt auf meinem MAC (OSX 10.10) die tty schnittstelle nicht (auch nicht in "Manuell") obwohl das Gerät auf der auf der Konsole klar erkennbar ist
user$ stty -a /dev/tty.usbserial-000012FD
speed 9600 baud; 24 rows; 80 columns;
Problem hier ist wohl die Baudrate umzustellen, ich habe noch kein sinnvolles konsolkommando gefunden
Also habe ich das Ganze auf der Windows Emulation installiert und das funktionierte dann wunderbar, führte aber zum
3. Problem
Die besagtem Modi ergaben kein sinnvolles Signalbild . Umschalten von z.B. gelb auf grün am Hauptsignal führte zu Hauptsignal ganz aus und Vorsignal gelb und umgekehrt. Zusätzliche Modi wie Signalstörung und Vorrücksignal machen das ganze noch übler. Letzlich konnte ich das Problem nur lösen mit einfachsten Signalmodi (2) und LED Modi für die Zusatzsignale (siehe angehängte Soll- und Ist-Files )

Hat mich ein paar Tage Arbeit gekostet und ist deswegen nicht so ganz befriedigend. Wer weiss hier mehr ?
Danke im Voraus
Bea N.
Dateianhänge
SV Soll.qconf
(13.69 KiB) 134-mal heruntergeladen
SV ist.qconf
(25.8 KiB) 132-mal heruntergeladen

Andh
Beiträge: 562
Registriert: 03.04.2015, 14:53

Re: SV Signale mit Z2-8 Signal nogo

Beitrag von Andh » 29.01.2017, 21:55

Hallo Bea,

ich musste ebenfalls feststellen, dass der Mode 92 in der Software nicht richtig ist.
Der Mode 93 wird vom Decoder als Mode 4 erkannt, passt also ebenfalls nicht. :o

Sorry, ist vorher nicht aufgefallen, weil die SV-Signale fast niemand nutzt.
Melde dich einfach bei info(at)qdecoder.com, dann erstellen wir Dir eine passende Konfiguration für deine Signale.
Der ordnungsgemäße Einbau der Modi für die SV-Signale wird hingegen noch etwas dauern. :cry:
Gruss aus Dresden
Andreas Hillert

Qdecoder Support Team

www.qdecoder.de
info(at)qdecoder.com
Tel: 0351/50036-95

BeaNoone
Beiträge: 10
Registriert: 28.01.2017, 18:25

Re: SV Signale mit Z2-8 Signal nogo

Beitrag von BeaNoone » 01.02.2017, 17:44

Prima danke. Gibt's auch eine Lösung für das MAC Problem? Was ich brauche ist, dass QRail die serielle Schnittstelle erkennt und ein Kommando um die von tty... Baudrate zu ändern

Gruss Bea N.

Michael Küttner
Beiträge: 123
Registriert: 31.03.2015, 08:57
Kontaktdaten:

Re: SV Signale mit Z2-8 Signal nogo

Beitrag von Michael Küttner » 01.02.2017, 21:59

Hallo Bea,

die Baudrate musst du nicht manuell auf der Kommandozeile o.ä. ändern.
Diese wird von Qrail beim Öffnen der Verbindung zur seriellen Schnittstelle festgelegt.
In den Qrail Einstellungen -> Verbindungen kann die Baudrate nochmal geändert werden. Hier sollte aber immer eine 57600 stehen.

Falls dein macOS Problem mit dem im Programmer verwendeten FTDI Chip hat, so hilft es vielleicht die neusten Treiber von der FTDI Internetseite zu installieren.
Siehe auch: http://www.ftdichip.com/Support/Documen ... _Guide.pdf

Auf meinem MacBook Pro (2013) war keinerlei zusätzliche Installation notwendig. Hier hat der Programmer direkt funktioniert.
Wie wird der Programmer denn in deinen Systeminformationen angezeigt?
mac-system-settings.png
mac-system-settings.png (112.52 KiB) 2771 mal betrachtet

BeaNoone
Beiträge: 10
Registriert: 28.01.2017, 18:25

Re: SV Signale mit Z2-8 Signal nogo

Beitrag von BeaNoone » 03.02.2017, 20:33

Hallo Michael,
ja stimmt, im Systembericht sehe ich den Programmer auch. Aber Qrail selber bleibt tot
. Ich werde es also noch mal mit dem Driver update versuchen

Danke und Gruss
Bea N.
Dateianhänge
Bildschirmfoto 2017-02-03 um 19.20.57.png
Bildschirmfoto 2017-02-03 um 19.20.57.png (57.4 KiB) 2758 mal betrachtet

BeaNoone
Beiträge: 10
Registriert: 28.01.2017, 18:25

Re: SV Signale mit Z2-8 Signal nogo

Beitrag von BeaNoone » 04.02.2017, 13:14

Hallo zusammen,

keine Chance die Vebindung von Qrail zum Decoder auf dem Mac zum Laufen zu bringen. Habe inzwischen den Serial Treiber und Java upgedated und neu installiert. der (Java-fehler) bleibt.

Gruss Bea N.
Dateianhänge
Bildschirmfoto 2017-02-04 um 12.10.53.png
Bildschirmfoto 2017-02-04 um 12.10.53.png (243.27 KiB) 2751 mal betrachtet

Michael Küttner
Beiträge: 123
Registriert: 31.03.2015, 08:57
Kontaktdaten:

Re: SV Signale mit Z2-8 Signal nogo

Beitrag von Michael Küttner » 04.02.2017, 21:37

Hallo Bea,

diese Meldung ist mir bisher noch nicht über den Weg gelaufen.
Verwendest du ein älteres macOS (z.B. Mountain Lion o.ä.)?

Qrail verwendet für die Verbindung zum Programmer eine Bibliothek namens "RxTx".
Die Fehlermeldung lässt vermuten, dass diese Bibliothek für deine macOS Version keinen passenden Wrapper mitbringt.

Nach ein bisschen googeln bin ich auf folgenden Hinweis gestoßen: http://blog.brianhemeryck.me/installing ... tain-lion/
Hier wird ein speziell angepasster Wrapper empfohlen, der sich unter dem folgenden Link direkt downloaden lässt: http://blog.iharder.net/wp-content/uplo ... ial.jnilib

Du könntest also mal versuchen nach dem Download die Datei "librxtxSerial.jnilib" in das Verzeichnis "/Library/Java/Extensions/" zu kopieren.
Evtl. behebt dies das Problem.

BeaNoone
Beiträge: 10
Registriert: 28.01.2017, 18:25

Re: SV Signale mit Z2-8 Signal nogo

Beitrag von BeaNoone » 08.02.2017, 16:15

Hallo Michael,
ich benutze zwar Yosemite 10.10.5, aber ja das war's. Der alte lib file war von 2006, der runtergeladene von 2009. Ich nehme an, dass ich die alte Version mit einer anderen Programmersoftware eingespielt habe, die auch über die Serialschnittstelle lief.
Die Verbindung scheint soweit stabil und schnell zu sein.

Super, Besten Dank und Gruss
Bea N.

Hobbychef
Beiträge: 63
Registriert: 05.04.2015, 18:03

Re: SV Signale mit Z2-8 Signal nogo

Beitrag von Hobbychef » 15.02.2017, 10:03

Hallo Bea,
im vorgestrigen Qrail-Update 2.4.7 ist eine neue Decoder-Firmware enthalten, in der auch dieses Problem behoben sein sollte.
Kannst Du das mal ausprobieren?
Viele Grüße
Thomas

Antworten