Updatefrust Qrail 2.4.8? Bitte um Softwarearchiv!

Alle Fragen rund um die PC Software Qrail
Antworten
fl_dutch
Beiträge: 59
Registriert: 21.01.2017, 23:14

Updatefrust Qrail 2.4.8? Bitte um Softwarearchiv!

Beitrag von fl_dutch » 01.03.2017, 00:53

Da war ich so froh, dass die Kombi Qrail 2.4.7, ZA2-16+ mit Firmware 9.12 in Verbindung mit Servos endlich funktioniert hat. Zig mal getestet im "Trockendock".

Heute wollte ich dann den Decoder auf der Anlage in Betrieb nehmen, aber fix noch die Ausschläge anpassen. Neues Qrail 2.4.8 aufgespielt - Parameter geändert und jeweils direkt am Wert geschrieben - ging noch. Nochmal Parameter geändert (fein Abstimmung) und nochmal "alle CV schreiben" - seit dem: in Sachen Servo wieder mal Funkstille.

Meine normale "Lichtversorgungsspannung" 16V Wechselspannung durch den Programmer Anschluss ersetzt (irgendwo war da was, dass die neue QDecoder etwas zickig bzg. Wechselspannung sind) - Pustekuchen. Nochmal Servo getauscht - nix. Beim Schreiben der Werte zucken sowohl neuer Servo als auch "alter" Servo noch. Beim Betätigen der "Tasten" in QRail zwecks Test: nix geht mehr.

Leider geht kein Weg zurück zu Qrail 2.4.7 - weil es die Version nicht mehr gibt.

Daher bitte bitte bitte: bei Updates vielleicht noch die jeweils letzten Versionen als Download vorhalten. Es kam jetzt in der letzten Zeit durchaus öfter vor, dass hier und da nach Softwareupdate die Sachen nicht das taten, was sie sollten. Vielleicht fehlt auch noch die Firmware 9.13, damit es wieder so funkioniert, wie es sollte. Die war aber leider nicht im Update mit drin :(.

Gut: man könnte jetzt sagen: never change a running system - aber es gilt auch: das Bessere ist der Feind des Guten :). Wieder mal ein wenig vertane Zeit mit Qdecoder :(.
Nette Grüße
Jens

Michael Küttner
Beiträge: 115
Registriert: 31.03.2015, 08:57
Kontaktdaten:

Re: Updatefrust Qrail 2.4.8? Bitte um Softwarearchiv!

Beitrag von Michael Küttner » 01.03.2017, 10:06

Hallo Jens,

ich habe im Download Bereich von qdecoder.de unter "Qrail + Qdecoder Software" -> "Qrail (ältere Versionen)" die Version 2.4.7 von Qrail abgelegt.
Die Problem mit der 2.4.8 werden wir versuchen schnellstmöglich zu klären.
Die neue Version behebt ein Problem, das beim Konfigurieren der ZA3-M4-96 Decoder aufgetreten ist.
Die Firmware 9.13 für die Decoder ist noch nicht fertig und wird auch nicht für Qrail 2.4.8 benötigt.

fl_dutch
Beiträge: 59
Registriert: 21.01.2017, 23:14

Re: Updatefrust Qrail 2.4.8? Bitte um Softwarearchiv!

Beitrag von fl_dutch » 01.03.2017, 16:51

Prima - mit Qrail 2.4.7 ging es dann wieder - aber nur, solange ich das aktuell angesteuerte Blinklicht und den Servo über den Programmer geschaltet habe. CVs habe ich vorsichtshalber jeweils einzeln geschrieben und nicht via "Alle CVs schreiben".

Sobald es aber mit der Tams Master Control geschaltet werden sollte, gab es Unstimmigkeiten - die gibts dann gleich im Decoder Sub-Forum.

Es scheint also zwischen 2.4.7 und 2.4.8 irgendwas anders zu sein, dass dazu führ, dass der Servo mit dem ZA2-16+ nicht mehr funktioniert.
Nette Grüße
Jens

Michael Küttner
Beiträge: 115
Registriert: 31.03.2015, 08:57
Kontaktdaten:

Re: Updatefrust Qrail 2.4.8? Bitte um Softwarearchiv!

Beitrag von Michael Küttner » 05.03.2017, 13:28

Hallo Jens,

könntest du uns die entsprechende Qrail Konfiguarationsdatei (*.qconf) zur Verfügung stellen?!
Damit wir das Problem besser einkreisen können.

fl_dutch
Beiträge: 59
Registriert: 21.01.2017, 23:14

Re: Updatefrust Qrail 2.4.8? Bitte um Softwarearchiv!

Beitrag von fl_dutch » 05.03.2017, 17:58

Die qconf ist leider nicht mehr da bzw. bereits mehrfach geändert - und den Spaß nochmal (Config mit 2.4.7 erstellen, testen, 2.4.8 installieren, testen, 2.4.7 wieder neu installieren...) - ich schau mal, wann ich dazu die Zeit finde.
Nette Grüße
Jens

fl_dutch
Beiträge: 59
Registriert: 21.01.2017, 23:14

Re: Updatefrust Qrail 2.4.8? Bitte um Softwarearchiv!

Beitrag von fl_dutch » 16.03.2017, 03:43

Das Problem scheint irgendwas im Zusammenhang mit meiner Tams Master Control, Wechselstrom und falscher Anschluss gewesen zu sein.

Habe nochmal Qrail 2.4.8 installiert (Decoder durch frischer Firmware Install "zurückgesetzt"), und noch weitere Änderungen vorgenommen und darauf verzichtet, alle CVs zu schreiben - damit funktioniert es (bis auf die Ruckel-Problematik - siehe anderer Thread). Werde da morgen nochmal Testen mit "alle CVs" schreiben. Dann gibts auch die aktuelle qconf Datei, falls es da ein Problem gibt.

Gibt es in Qrail die Möglichkeit, alle CVs aus dem Decoder auszulesen und diese in eine csv-Datei zu schreiben? Dann könnte man einfach vergleichen, ob da "was Lustiges" geschrieben wird - Hinweis auf ein passendes anderes Tool wäre da auch willkommen.
Nette Grüße
Jens

Andh
Beiträge: 510
Registriert: 03.04.2015, 14:53

Re: Updatefrust Qrail 2.4.8? Bitte um Softwarearchiv!

Beitrag von Andh » 16.03.2017, 09:23

Hallo Jens,

ein "alle Lesen" für alle CVs gibt es leider nicht.
Aber man kann in jeder Kategorie "alle Lesen" machen und die ausgelesenen CVs dann aus der CV-Listenansicht in CSV exportieren.

Zum Vergleichen gibt es mehrere Tools tkdiff fällt mit da auf Anhieb ein.
Gruss aus Dresden
Andreas Hillert

Qdecoder Support Team

www.qdecoder.de
info(at)qdecoder.com
Tel: 0351/50036-95

Antworten